Application failed to run on Mendix cloud

I am getting following error while trying to deploy app on mendix cloud.  Note: This is a free app .   I tried to visit the log page but it is again giving different error on that page : This is very basic app having no entities and databsse connection configured. What is wrong here?
3 answers

Try to deploy your app again. If it fails again, it sometimes helps to clean the deployment directory. 
'Clean Deployment Directory’ in the modeler under Project in the menu 
In forum question 94098 a developer is facing a similar problem ( This is a recent problem.


re-run might indeed be a successful way to get it done.

Also when having issues of any kind with the Mx platform, take a look here first; 



Try installing Tortoise SVN 1.7 and right clicking on the Mendix project directory, select Tortoise SVN then select Clean Up and select the Clean up working copy status checkbox, then select OK, this usually helps me resolve this issue when I run into it. 

If that doesn’t work then I usually run the application from Eclipse, this way always works for me.  Here are the instructions on how to run your Mendix application from Eclipse,