An error occurred while initializing the Runtime: null

From the below I can deduce that a Decimal is Null.   However since my last successful run I have not added any new decimal columns to the Tables.   How do I get around this issue?   Tried: Restarting. Deleting my App from my Local Drive. Taking Out my most recent changes. Nothing seems to Fix the Issue.   The only fix I can think about is to Export my Code.   Then create a New App and Import my Code, so it produces  new database without the Corruption. An error occurred while initializing the Runtime: null -------- com.mendix.m2ee.api.AdminException: An error occurred while initializing the Runtime: null  at com.mendix.basis.impl.MxRuntimeImpl.start( Caused by: java.lang.NumberFormatException: null  at java.math.BigDecimal.<init>(  at java.math.BigDecimal.<init>(  at java.math.BigDecimal.<init>(  at com.mendix.basis.objectmanagement.member.internal.MendixDecimalImpl.getValueFromString(MendixDecimalImpl.scala:32)  at com.mendix.basis.objectmanagement.member.internal.MendixDecimalImpl.parseInitialValueFromString(MendixDecimalImpl.scala:25)  at com.mendix.basis.objectmanagement.SchemeManagerImplBase.createPrimitive(  at com.mendix.basis.objectmanagement.SchemeManagerImplBase.createMembers(  at com.mendix.basis.objectmanagement.SchemeManagerImplBase.createInstance(  at com.mendix.basis.objectmanagement.SchemeManagerImplBase.initializeObjectInstances(  at com.mendix.basis.objectmanagement.SchemeManagerImplBase.initialize(  at com.mendix.basis.component.internal.LocalComponentImpl.initializeSchemeManager(LocalComponentImpl.scala:80)  at com.mendix.basis.impl.MxRuntimeImpl.initializeCore(  at com.mendix.basis.impl.MxRuntimeImpl.start(  at com.mendix.m2ee.appcontainer.actions.StartAction.startRuntime(  at com.mendix.m2ee.appcontainer.actions.StartAction.execute(  at com.mendix.m2ee.appcontainer.server.handler.HttpAdminHandler.handle(  at org.eclipse.jetty.server.handler.HandlerWrapper.handle(  at org.eclipse.jetty.server.Server.handle(  at org.eclipse.jetty.server.HttpChannel.handle(  at org.eclipse.jetty.server.HttpConnection.onFillable(  at$ReadCallback.succeeded(  at  at$  at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.runTask(  at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.doProduce(  at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.tryProduce(  at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.produce(  at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(  at org.eclipse.jetty.util.thread.QueuedThreadPool$  at
3 answers

How do I use pgadmin.or?

Tried renaming the database but this does not work.

I have also changed all the Calculated Fields to Stored fields with a Default Value of zero but this does not work.

How do I delete the current database it start again, as this may fix the issue?


Tried importing the Module into another App, but this has the same issue. The only way I can think of doing this is to Delete tables 1 at a time for the bottom until the App Builds (Exclude from Project all microflows and pages that use the tables).


Check your database for empty values using pgadmin or to create a New database, you can change the name of the database in the project settings in your Mendix modeler:

For pgadmin see

Renaming your database will, once you run locally again, do all the steps and at the end show you that it is going to create a new database:


Hi !

How do I delete the current database it start again, as this may fix the issue? :

- Make sure you have the backup of your project

- Project > Show Project Directory in Explorer >  delete the “deployment” folder