Unable to add NTP server

Hello All,   Please, kindly assist in resolving the below issue. I’ve created and successfully onboarded the new IED to the existing IEM. I checked the IED operation and everything worked smoothly. I was able to install and uninstall applications, perform rests, etc. After that I ran the test described in the Device Builder Docs – Development – Integration – Testing an Edge Device documentation section. Upon running the  sudo bash runtest.sh script I received the error message about AssertionError in the device onboarding stage.   After that it turned out to be impossible to even manually onboard the same IED to the same IEM. I removed the IED from the IEM. Re-created it, received the new onboarding device file. After that when I am trying to manually onboard the IED i inevitably receive the following message in the IED interface::   Activate Edge Device Device config file A different network configuration in the onboarding JSON will invalidate the current browser tab. Unable to add NTP servers. Settings   I’ve tried to manually add the NTP server in Settings – System. It’s really missing: NTP Server Servers Server Name No servers added. Missing NTP configuration may break your communication with server.   But the result is the same. When pressing the Submit button I receive:   NTP Server Servers Server Name Prefer     Server Name     Action us.pool.ntp.org      In case you configure invalid NTP servers, it may stop NTP services. The server encountered an unknown error.   The NTP is configured as follows in the IEM:   NTP Server Servers Server Name PreferServer NameAction   us.pool.ntp.org In case you configure invalid NTP servers, it may stop NTP services. If the NTP server is located within a local (not proxied) network, please add the FQDN of the NTP server into the No Proxy section.   Enable IEM as NTP server Use the IEM NTP settings for the IED – checked Auto Restart NTP – checked It may introduce time jump.   Please, advise how to resolve this issue.   The IED is under Debian 12. The testing machine is under Ubuntu 22. The IEM is running under Ubuntu in the Vmware virtual machine hosted by Windows 10.   Thank you in advance.        
1 answers

Hi Yuri, I hope I was able to understand your issue and that is that you are unable to onboard the device again. In that case you will need to hard reset your IED by flashing it using a service stick to be able to onboard it again. Here is the relevant documentation:


It is known that you might face some errors when you try to onboard a device that was once onboarded before.