IIH ESSENTIALS - Asset list and child list disappeared

Hello everyone,   When open IIH Essential, the Asset list and child list disappeared. The error message is:    "Invalid parameter - The Asset.parentId parameter is invalid: Parent asset not found."     Is there any fix for the error ?           ​​​​​​​
4 answers

Hi Felipe,


could you describe what steps you have done before this error occured? Have you added, edited or deleted some Assets or child Assets?

When opening the asset view what is currently displayed? Do you see some Assets like the "edge" Asset or none at all?

Can you share screenshot?


Would it be possible to share two things IIH Essentials

1. Full logfile

2. Files from IIH Essentials Volume: Open IED UI > Management and select IIH Essentials. On the right side you see Application Volumes. In there you find a folder called Assets. Can you download all the files.



Hi Thomas,


OneDrive - Log and Screenshot


Steps before error:


1 - Virtual Device reached 96% storage

2 - Performance Insight slowed down and showed error message number 503 

3 - Deleted unused applications

4 - Reboot Virtual Device

5 - IIH stopped showing assets


Additional Information:  today, when trying to export the list of assets and data, it happened correctly and I saw all the assets in the backup.


Is uninstalling IIH, installing again and restoring the backup a valid option ?


I would recommend to you expanding the disk of the virtual edge device.

This can be done by shutdown of the VM and expanding the disk in the VM settings. During the boot the virtual edge device will expand the partitions and you will have more disk spaces available.


After that I would check whether the Assets are again correctly loaded. If not you can uninstall IIH Essentials and install it again and restore the backup. I would not recommend doing it without expanding the disk in advance as the backup will again fill up your disk spaces.


Thanks for the feedback, knowing how to expand the disk was a question I had.


Here's the solution I found:


1 - Reinstall IIH.

2 - Attempt to restore the backup.

3 - The error message was displayed again.

4 - Investigating backup .json file, I found a child asset with a non-existent ParentIdI. 

5 - Created the AssetId manually in the .json file with the missing ParentId code

6 - I tried restoring the backup and it worked


I don't know how a child asset continued to exist even without the existence of the AssetId, but in any case: make a backup