Receiving x-www-form-urlencoded in exposed REST service

Hey folks, I'm running into some issues integrating a callback function and could really use some pointers. I'm exposing a rest service for an external resource to interact with. It's a POST method with a content type of x-www-form-urlencoded. On the external resource side everything looks like it's working fine, but in Mendix the Content field of the incoming httpRequest is empty.   I've looked at all the forum posts and documentation, and nothing I do seems to be working. I’ve configured the service to only have a parameter of type HttpRequest, but as you can see in the screenshot below, the Content field is still empty. I’ve tried to configure Form parameters for the service, but those come back empty as well, and from my research they only really work for multipart forms. I’ve tried to mimic the callback functionality in the OIDC module too, which happens to just be manual handling of the HttpRequest, but it’s always the same outcome that you can see below:   These are the logs of the external resource and what they’re sending over: Any pointers or help would be greatly appreciated! Thanks in advance, Austin
0 answers