Disallow request with Custom Authentication for Published REST service

Hi, when you add a custom authentication layer to your published REST service, how do you throw an authentication error with Mendix default features?   I have configured a Published REST service and 2 parameters.     and this is the start OnAuthMyService microflow.   However, If you call the REST service without one of the parameters, the flow will end up with an empty User. This is not returning an authentication error though.. I just get the access to the REST resource.   How can you tell the Mendix (and the user) that we don't allow this call? How can you return a "Authentication failed." message properly?
1 answers

Did you try adding a System.HttpResponse parameter to the microflow?