Using Personal Certificate on Mendix Server on Premise

I see a lot of questions and answers dealing with configuring certificates on on-premise servers (like I think I tried the most of them, but I still get a handshake error. Most answers are not very clear in where to use the quotation marks and where not, so maybe that is my fault. Based on many answers I added the following lines to the Settings.yaml: Service: ClientCertificates: E:\Certificates\ ClientCertificatePasswords: demo ClientCertificateUsages: {"", "E:\\Certificates\\"} From the Mendix Modeler there is no issue. Added the certificates via Project → Settings → Certificates is easy and tests results in a correct call of the external soap-service. So the certificate is correct. Can somebody see what I am doing wrong here and if this should be the only thing to do?
1 answers

We use Windows 2016 Server.

I solved the problem by not adding the extra settings to the Settings.yaml.

Go to the Mendix Server Console / Settings / Advanced and add the lines to the Custom Mendix settings: see image: