REST GET request with encoded character gives 404 error in MX8 (but works in MX7!)

Hi, I get a ‘404: Not Found’ error when I try to do a Get Rest call to the following URL: As you can see the ‘scto%3A11259780’ part in the URL is encoded this was ‘scto:11259780’ In MX 7.23 everything works fine with exactly the same microflow call (and URL). Also in Postman everything works fine (offcourse) with the following url and parameter ‘student’   Is this a bug in Mendix 8 (tried 8.1.1 and 8.4.1) or do I need to modify the url in one way or another? Thanks
1 answers

Hi Cillus,

  I have tried several different permutations of using %3A, ‘:’, urlEncode(‘:’), and other methods and I can confirm what you are seeing. I get a 404 in postman and a ‘no Oauth Credential’ in postman, which is what I would expect. I do know that some behavior in encoding/decoding URLs changed in the release of 8 as outlined in this release note:

 We fixed an issue in consumed REST services where encoded URLs were decoded too early. We upgraded httpclient.jar from 4.5.7 to 4.5.8. (Ticket 83346)

 So I would indeed recommend that you create a ticket with support for this.