[Solved] Compilation error

Hello everyone, I am trying to upload a new version to the mendix cloud and it won't let me because I get the following error:   [compile] 2023-04-22T10:44:06.626029316Z Executing step 'Clean up' [compile] 2023-04-22T10:44:06.626158873Z * Cleaning up... [compile] 2023-04-22T10:44:06.842765352Z ERROR: An error occurred while compiling Java actions [compile] 2023-04-22T10:44:06.842787366Z > Task :clean-custom-classes [compile] 2023-04-22T10:44:06.842790074Z [compile] 2023-04-22T10:44:06.842792010Z > Task :compile [compile] 2023-04-22T10:44:06.842794185Z /workspace/build/source/javasource/encryption/pgp/PGPUtils.java:362: error: cannot find symbol [compile] 2023-04-22T10:44:06.842796472Z spGen.addSignerUserID(false, it.next()); [compile] 2023-04-22T10:44:06.842798541Z ^ [compile] 2023-04-22T10:44:06.842800455Z symbol: method addSignerUserID(boolean,String) [compile] 2023-04-22T10:44:06.842802356Z location: variable spGen of type PGPSignatureSubpacketGenerator [compile] 2023-04-22T10:44:06.842804345Z Note: Some input files use or override a deprecated API. [compile] 2023-04-22T10:44:06.842806220Z Note: Recompile with -Xlint:deprecation for details. [compile] 2023-04-22T10:44:06.842808125Z Note: /workspace/build/source/javasource/barcode/actions/GenerateBarcode.java uses unchecked or unsafe operations. [compile] 2023-04-22T10:44:06.842810150Z Note: Recompile with -Xlint:unchecked for details. [compile] 2023-04-22T10:44:06.842821156Z 1 error [compile] 2023-04-22T10:44:06.842823362Z [compile] 2023-04-22T10:44:06.842825588Z > Task :compile FAILED [compile] 2023-04-22T10:44:06.842827559Z [compile] 2023-04-22T10:44:06.842829335Z 2 actionable tasks: 2 executed [compile] 2023-04-22T10:44:06.842831225Z FAILURE: Build failed with an exception. [compile] 2023-04-22T10:44:06.842833149Z [compile] 2023-04-22T10:44:06.842834923Z * What went wrong: [compile] 2023-04-22T10:44:06.842836819Z Execution failed for task ':compile'. [compile] 2023-04-22T10:44:06.842838661Z > Compilation failed; see the compiler error output for details. [compile] 2023-04-22T10:44:06.842840572Z [compile] 2023-04-22T10:44:06.842842378Z * Try: [compile] 2023-04-22T10:44:06.842844131Z > Run with --stacktrace option to get the stack trace. [compile] 2023-04-22T10:44:06.842846006Z > Run with --info or --debug option to get more log output. [compile] 2023-04-22T10:44:06.842847909Z > Run with --scan to get full insights. [compile] 2023-04-22T10:44:06.842849740Z [compile] 2023-04-22T10:44:06.842851469Z * Get more help at https://help.gradle.org [compile] 2023-04-22T10:44:06.842853366Z [compile] 2023-04-22T10:44:06.842855119Z BUILD FAILED in 14s [compile] 2023-04-22T10:44:06.842856909Z [compile] 2023-04-22T10:44:06.842858631Z [compile] 2023-04-22T10:44:06.843453287Z BUILD FAILED I tried to remove the encryption module and reinstall it. Thanks!
1 answers

Just adding the answer here so this can really be marked as solved: