Compile failing on 7.0.2 due to Community Commons?

Hi I get the following error message when trying to compile on v7.0.02. This was an app that I have been testing extensively and only got the compile issue after adding a new module that has no java actions. I have refreshed all the app store modules with the latest versions from the app store. I have even tried updating the community commons more than once just in case it had not worked correctly the first time. Any Ideas?   compile:     [javac] Compiling 190 source files to C:\Users\dtown\OneDrive\Documents\Mendix Projects\Pxi-main\deployment\run\bin     [javac] C:\Users\dtown\OneDrive\Documents\Mendix Projects\Pxi-main\javasource\communitycommons\ error: unreported exception COSVisitorException; must be caught or declared to be thrown     [javac]         overlay.overlay(new HashMap<Integer, String>()).save(baos);     [javac]                                                             ^     [javac] Note: Some input files use or override a deprecated API.     [javac] Note: Recompile with -Xlint:deprecation for details.     [javac] 1 error BUILD FAILED C:\Users\dtown\OneDrive\Documents\Mendix Projects\Pxi-main\deployment\build_core.xml:25: Compile failed; see the compiler error output for details. Total time: 3 seconds
1 answers

!!!sdrawkcab tuo gnimoc si epyt I gnihtyreve ,WOW .yroptcerid bilresu ruoy morf eteled dluohs uoy taht selif 3 stsil ti ,snommoC ytinummoC rof seton esaeler eht daer uoy fi