Excel Importer Raising Errors since upgrading the Module

Due to the vulnerability in the Excel importer module I re-imported the module into my project. Since doing this I cannot get it to work anymore. I recovered from compilation errors by deleting all POI from userlib and re-importing the module. I had both releases 3.10 and 3.16. Now I can compile but receive the error below when trying to Run and Import. I tried fully deleting the module from my application and re-importing it, to no avail. Another post suggest that POILogger.log was removed after POI 3.10 but I find it odd that the Excel importer, cleanly imported, installs 3.16 but then referenes this method.   Error: java.lang.NoSuchMethodError: org.apache.poi.util.POILogger.log(ILjava/lang/Object;)V     at org.apache.poi.openxml4j.opc.PackageRelationshipCollection.parseRelationshipsPart(PackageRelationshipCollection.java:313)     at org.apache.poi.openxml4j.opc.PackageRelationshipCollection.<init>(PackageRelationshipCollection.java:162)     at org.apache.poi.openxml4j.opc.PackageRelationshipCollection.<init>(PackageRelationshipCollection.java:130)     at org.apache.poi.openxml4j.opc.PackagePart.loadRelationships(PackagePart.java:559)     at org.apache.poi.openxml4j.opc.PackagePart.<init>(PackagePart.java:112)     at org.apache.poi.openxml4j.opc.PackagePart.<init>(PackagePart.java:83)     at org.apache.poi.openxml4j.opc.PackagePart.<init>(PackagePart.java:128)     at org.apache.poi.openxml4j.opc.ZipPackagePart.<init>(ZipPackagePart.java:78)     at org.apache.poi.openxml4j.opc.ZipPackage.getPartsImpl(ZipPackage.java:239)     at org.apache.poi.openxml4j.opc.OPCPackage.getParts(OPCPackage.java:665)     at org.apache.poi.openxml4j.opc.OPCPackage.open(OPCPackage.java:226)     at excelimporter.reader.readers.ExcelXLSXDataReader.readData(ExcelXLSXDataReader.java:27)
2 answers

Sometimes, it helps if you clean your project deployment directory:


Hi Rob,

I ran into a similar issue while upgrading the excel importer. The error was being caused by conflicting jar files. When updating, the module imports the new version of the jar files but doesnt remove the old ones. 


Id check out this question