ProcessQueue stops and QueuedActions keep having status Open

Hello, We are using processqueue version 3.2 in mendix 6.10.10 / mendixcloud V3 We have implemented the processqueue for several months now but now for the second time in two weeks it just stopped processing in our production environment. All QueuedAction keep having status Open. We impemented the scheduled event SW_ReinitializeQueues and checked whether this was activated (by debugging). But Reinitialize has no effect. Restarting the application fixes the problem and all queued actions with status open wil be processed. Is there anyone with the same problems or anyone who has a suggestion how to solve this problem? For now we created a new button wich executes BeforeShutdown_Shutdownqueues and Afterstartup_InitializeQueue and hope that we can get the queue active again when it stops again without having to restart the application. Time will tell whether this wil actually do the job if the problem will happen again. Are there any known risks executing those shutdown/startup microflows in a running application?
3 answers

I had a problem like this. It was a bug in my own code. I did not append the actions to the queue using the java action. The queued Objects have been there but they have only been executed after a restart. Calling the appendnewactiontoqueue java action after creating the QueuedAction solved the problem.

But if it is only happening sometimes and on existing code, it might be something else.


For me the queued jobs had status unqueued when they stalled so it might not be the same problem as you have had. Reinitialized did not do us any good either

I have tried the solution in these threads, and so far it seems to not stall:


Today again a problem where the que stopped running.
It's getting annoying.

The implemented solution to restart the processque (executing BeforeShutdown_Shutdownqueues and Afterstartup_InitializeQueue) had no result.
I had to restart the mendixapp to get it going again.

After restarting all queues work fine.