Copy attributes from entity to another

Hello, I have an entity called Tenders with five attributes called PublicatieId of type Integer which is also key, AanbestedingNaam of type string, AanbestedendeDienstNaam of type string, Europees of type boolean, Kwalificatie of type boolean. I also have another entity called Bids with the same five attributes (same name and type) and a bunch of other attributes. So these two entities share the same five attributes. I would like to create a microflow that copies the content of these shared attributes from one entity to the the other one. I know that in CommunityCommons via the App Store there is module called copyAttributes that should be able to do this. I have tried to understand how this works and searched for it on the net, but to no avail. Could you please explain it in some detail how to use this module called copyAttributes, or point me to a (detailed) explanation?
3 answers


I created a small example of this.

Here is the domain model:

Here is the microflow where attributes are copied

This is the way to copy attributes with the Java action you mentioned

If that doesn’t work for some reason, you could also copy attributes with a Change action, like this:

Hope that helps,




You can use copyattribute java action to copy all attribute from source entity to destination entity.It should copy all values.

Try microflow like this,

Hope this will help you



EDIT: ok, I have solved the problem: you can't copy attributes to an object that doesn't yet exist. I have created an object in the entity Bids and now it works fine. Thanks once again, Mike.


Hi Mike,

I have a data grid of entity Tenders and with that data grid is button 'Prekwalificatie'. When a selection is made in the list that is presented in the data grid aand the button gets pressed, the microflow you helped me should start and copy the  5 attributes from entity Tenders to entity Bids.

The entity Bids is completely empty at the moment and there are no objects in it. I don't know whether I need to create an object before I try to copy the attributes, but made the presumption I didn't need to. The microflow that I created looks like this (see screenshot below).


If I look at the on-click microflow settings I see an error at Target that says ‘No applicable value available’ (see screenshot below).


If I  look at the microflow I see an error CE1574 (see included screenshot below) and I think there is something wrong with the target.

I seem to be close to my goal of succesfully copying those five attributes, however I don't know how to fix this error; could you please have a look and help me out?