DownloadFile action Not working (not an access issue)

Hi, I have tried everything I can think of so hoping someone can give me some debugging clues. Our application has two related entities, say Object A and Object B. There are two different sections of the app with data grids. One section shows a datagrid of ObjectA and has an action button that takes the list and exports it to pdf, using pdf templates and the download file action, call this MicroflowA. This all works. The second section has a list of Object B. It also has an action button that gets the related list of object A and passes it to MircoflowA (to generate the pdf and download the file). This second flow does not work. I have tried it with the same list, MicroflowA does exactly the same thing in both instances, checking variables during debugging the pdf is not downloaded but all microflows get to the end event. There are no errors in the console, it is the same user accessing both buttons, so same access rights. I turned all logging to trace and found no hints. Checked developer tools in the browser and it looks fine. Using Mendix version 8.18.4. 
0 answers