POST character encoding

Hi there ! I post a message with REST to an external server (Amplitude), and when I send strings with special characters (like in my first name : “françois”), Amplitude receives “françois”. → how can I fix that ? I tried to add something in the header like “Content-type”  with value “application/json;charset=utf-8”, but it doesn’t change anything. And I can’t even find a way to log the POST request ; I can only log the payload in my microflow, which shows “françois”, but I don’t know what is the charset used. Any idea ? Thanks !
1 answers

You can set the log level of “REST Consume” to TRACE, and I think that should show you what is being sent and received when you call the external server.

Another thing to try is to send a REST request to Amplitude using a tool like Postman so you can see if the problem is with Amplitude or with Mendix. If you get the same result with Postman, it’s probably Amplitude, if not, it’s Mendix.

Good luck!

Update: Log level should be on “REST Consume”, my original answer said “REST Publish” and this has been corrected.