Time outs thrown when accessing application behind the Chinese firewall

For a project we have an application that is hosted in the EU. The application should be both accesible in the EU and China. Because of the "Great Firewall" the application it self is pretty slow, but in some occasions there are several errors thrown by the client (browser) that we cannot relate to anything specific, the client side it self is called with a DeepLink (so no chance of running it Asynchronous?). Most of them will show:  - Failed to load resource: url/mxui.js?randomstring not found - Uncaught SyntaxError: Unexpected end of input -- mxui.js?randomstring   We tried several things but most errors are not viewable in the logs because they occur on the client side in the browser. One of the things we tried was finding out if there is any timeout variable in the m2ee.yaml file (we use Docker hosted on Azure), but without success.
1 answers

Are you using a web server (like NGINX?) in front of the Mendix app? If not, be sure to add it.

If you do have a web server, ensure that it's serving up the static content (like mxui.js) and that compression is enabled.

If that doesn't solve it, I think you can increase the NGINX timeout like they suggest here.


Let us know how it goes!