Fields dont update in form on microflow onChange that youve edited

I have a nested listview with 1 editable field for each object shown. The editable field has an onChange microflow, which updates all other (uneditable) data on the page. It calls a microflow, loops through all objects, changes them, and then commits the list with refresh. That works perfectly fine. I also have a Call Microflow button which updates the editable fields with a default value. I push the button, it calls the microflow, it loops through the objects, updates them, and then commits them with a refresh. This also works fine. Where it goes wrong, is when I do a combination of both. First I edit one of the fields, which calls the onChange microflow. Then I push the button to reset the default values. It then resets all the fields I did not edit before. It's like the client knows what fields you touched on while being on this page, and excludes them from the Refresh action in the Commit. If I then press F5 to refresh the page, it does show the updated values (which I can also see while debugging). So it does change and commit the fields, but it doesn't update fields in the browser, but only if you've edited them during the same page-visit. I've tried closing the page and reopening it at the end of the microflow. I've tried always updating the value (to the same value, but also to a totally different one). Nothing seems to work. Any ideas?
1 answers

You said it is a nested Listview - did you try committing the parent object with refresh?