Cant edit entity for registration even when created in the microflow

I'm trying to sign-up an user through wizard steps where the person is able to edit his user details (page 1) and then the adress (page 2) but is not able to edit subscription (page 3). Following domain model: Following “NewAccount” Microflow: With this microflow I can make the object adress editable in the registration form (page 2) and I'm able to link it to the user when he is logged in and goes to his profile page. The profile page contains a list view by xpath: [id = '[%CurrentUser%]'] in order to properly link it to the user. For the adress page (page 2) I'm using a nested dataview over associaton AccountPasswordData/User/User_Adress. In the nested dataview I have a referenceselector with the following path: MyFirstModule.User_Adress/MyFirstModule.User/System.User.Name. – Selectable objects source has a xpath: [id = '[%CurrentUser%]']. When the user is on the subscription page (page 3), the user can't seem to edit it. Which also means subscription isn't linked to the user. So i tried the following microflow: I tried using the same method of the nested dataview over associaton AccountPasswordData/User/User_Subscription. In order to edit the object I basically need to create the object first, but this just doesn't work. I didn't really change the SaveNewAccount microflow just deleted the “Delete AccountPasswordData” activity and added a show page activity to adress (page 2) (otherwise I can’t show the adress page (page 2), because the show page activity goes over the object AccountPasswordData, which is needed in the nested dataview). I basically need the user to be able to sign up and sees his account information on his profile page (containing user, adress and subscription). How can I solve this problem?
0 answers