User receives error message while server is still busy building the page.

What can cause this phenomenon: User receives an error message while the server is still active with building the page. Steps: In an email a deeplink is clicked.  The deeplink is found and the linked microflow is started, the input parameters have correct values.  The last activity of the microflow (Open Page) is reached without any problem, debug is waiting on that activity. In debugging we click Step-over and this results opening the page. At this point: - the user receives the standard error message "An error occured. Contact your systemadministrator".  - In the log there is no line added. Nothing. - The debugger ends up in the only datasource-microflow that is on the Page that Mendix is now building. It is not a timing issue. We have tried waiting and continuing at diverse intervals. Same result everytime. It happens with one user only. And it is the only problem that this user is currently facing (related to this app, that is). This user has been working fine with this app for years and has one role only. Other users ave no problem.  It happens on phone and on desktop.   *Edit* Answer is: the page-building completed and crashes on a missing authorization, but the server was already continuing with a calculation-microflow.
1 answers

Hi Tim,

Have you checked that user has the correct permissions to view all of the data on the page? Also did you check the browser console for additional errors? If the data on the page is user specific, its possible that an empty value or a calculation is throwing an error?