long-running property

In the forum there are discussions about setting the long-running property of a microflow. The documentation section doesn't mention it. And I can't find it anywhere in the properties in the modeler. How to do it (7.8.0). My microflow is throwing an error because it is taking longer time to fetch data. 
3 answers

First time that I hear of the ‘long-running property’ of a microflow as referred to in https://forum.mendix.com/link/questions/272. Apparently it is there to prevent the client-side from resending the request when the client-side thinks the wait for a response is too long. Thus the microflow gets called a second time for no good reason.

The ‘long-running property’ of a microflow is not or no longer a microflow-property so you cannot prevent the client from making the call again. But you can prevent the microflow from starting when it is already running by using the microflow property 'disallow concurrent execution’:

Mind the double negative, “Disallow: No” means it is ok to start when running. “Disallow: Yes” means it is not ok to start when running. 


You are probably referring to the asynchronous option. This is a property set when a microflow is called from a page

See this link for more information: https://docs.mendix.com/howto/logic-business-rules/triggering-logic-using-microflows#3-3-3-execution-section


Hi Nikhil

Use the offset and limit to retrieve the large data and process them(using Batches)

Also see this link for reference