Viewing App on Testing mobile Device

Hi All, We are trying the view the app on mobile devices, and follow the same steps ( error, please find the attached image. Steps: Make It Native App is installed in mobile  both Mobile and system  connected the same network  “Scan a QR code”  after the scan we are getting this error    
2 answers
  1. Try stopping the Mendix app and then Run Locally again. Make sure devices are on same network before running the application. 
  2. Also check if your antivirus or firewall is blocking communication with Make it Native app. You can try disabling it and then check if it works. I had experienced issues with firewall due to which native app preview was not working.
  3. Check for any updates to make it native app. Update the app to latest version
  4. If using Mendix version 8.8 or below, you need older version of Make it native app available in make it native archives link in documentation

The following steps worked for me to open my app within de the Mendix Native App and open my app in the browser when I fill in my IPv4 adres + :8080 (didn't have to disable my whole firewall):

First, the steps that Mendix recommends:
1. Be on the same network as your mobile device
2. On your computer with WiFi, set properties to "Private" instead of "Public"
3. In project settings under your 8080 server tick "open to other machines"

If it still doesn't work after this, which it was the case for me, you can try this:
1. To firewall & Network security
2. To advanced settings

3. Set OpenJDK Platform Binary to 'allow connection' and 'profile' = 'all':
Double click on the line -> check 'allow connection' -> go to tab 'advanced' and check all 3 profiles. See the photo below for an example of how the settings should look. (if needed, repeat this steps with the 'Mendix Native Mobile' line)
4. Check if it is working now. If not, you can still try the following steps.

5. Within the tab 'Rules for incoming connections' right click on the tab and then 'New rule'
6. Check the line type 'Port'
7. Choose TCP and fill in at 'specific local ports': 8080 (port 8083 may also be useful to allow, this uses Mendix in some cases)

8. Now it should work!