Unable to display PDFs in a hybrid app for iPhone created with Apache Cordova.

I am unable to display PDFs in a hybrid app for iPhone created with Apache Cordova. I was using JavaScript to execute the following URL to display the PDF, but now there is no reaction when I tap the button. window.Open("https://[AppURL]/file?guid=xxxxxxxxxxxxxxxxxx","_blank","EnableViewPortScale=yes,location=no"); (The guid is Sysytem.FileDocument)   When I created the app with PhoneGap before, it worked. I migrated to Apache Cordova because PhoneGap is ending. We are using XCode13 for build and archive.   There are no app errors or server log output. I tried replacing it with [ cordova.InAppBrowser.open() ], but that didn't solve the problem. When I try to place the Microflow button and run FileDownLoad, an error occurs in the app and I get a SystemText [Error: internal error] message. The Mendix version is 7.23.19. I can't immediately upgrade to Mendix 8 or later. iOS 15 (+ recent versions such as 14). Also, it is a business requirement to provide it as a hybrid app.   Is there any solution, such as another implementation or build settings? Please let me know. thank you so much for responding in advance.
1 answers

I found that the InAppBrowser plugin, which was present in my previous app, was not added to this app.
I added the InAppBrowser plugin manually, and the Download File action displayed the PDF without any problem.
# cordova plugin add cordova-plugin-inappbrowser