Make it Native 9: Unknown host

In my app I have a native profile. I start my application locally (F5); looks ok I click menu option “View App” => “View on my device” and select the tab “Native profile”; it shows the QR-code on my laptop-screen; On my phone (NB connected to the same wifi-network) I open the app “Make it Native 9”, which is recently updated I scan the QR-code and the app “Make it Native 9” starts trying to connect to the application running on my desktop, but fails and show “Something went wrong” and “Cannot connect wit Mendix Studio Pro. Use the option below to test the connectivity of the device to the runtime” So I use the option below: “Test connection” which opens the browser and attempts to connect to (my app is indeed running on port 8086) and it fails. There seems to be no possible connection to the url. From my phone I sent a ping to this ip-address, same error result, “unknown host” Something seems to be preventing my laptop from exposing But what. How to make available? Other tests I did: Pinging from another phone gave the same “unknown host” response. Moving to another building picking up another wifi-network. Same result. Took down my firewall (feel so vulnerable now...). Same result. What am I missing?  
2 answers

I have experienced this error multiple times. Not sure about what causes it, but here are some solutions/workarounds for it. Anyone of these randomly works and issue is resolved somehow. I couldn’t understand actual reason behind it.

1) If you haven’t already looked, here are some things to check as mentioned in docs:

Other steps I have tried whenever this error appeared. No sequence in these and not all were done at once. I keep trying until issue is solved

  • Check Windows updates, update to latest version available
  • Restart Windows
  • Re-install Mendix Studio Pro
  • Reconnect Wi-Fi
  • Connect/Disconnect VPN (if any)
  • Re-install Make it Native 9 app
  • Disable firewall, real-time protection in antivirus software
  • Disable Windows defender firewall
  • Allow port 8083 for communication on public/private network

Hi Tim,

I experienced this whenever i was connected to a wifi network with type public. Make sure you set the wifi connection type to private aka 'home' or 'work' instead of public.