App store connect operation error asset validation failed.

Hi, We are trying to upload app on Apple Appstore using xcode. We are getting below error. This is regarding libMendixNative.a file.     Kindly suggest any resolution for the issue.   Thanks, Uddhav.  
1 answers

Hi, I ran across this issue myself (and then this forum post). After several hours of investigation I discovered the problem for me, and I’m posting here in case anyone else gets the same error. With a Mendix Native Template open in XCode, if you click “nativeTemplate” in the project navigator, then click nativeTemplate under  “TARGETS.” Scroll to the bottom of the page where it says “Frameworks, Libraries, and Embedded Content.” By default, it says “Do Not Embed” next to “mendixnative.xcframework”. I had this set to “Embed & Sign” which triggered the error message you see above. Changing it back to “Do Not Embed” fixed the issue for me. You might also want check the dev target for the same setting as well. 


I found this because we have several frameworks we have added to our native template that do require it to be set to “Embed & Sign” and in an update, the mendixnative.xcframework was set to the same setting as those external frameworks. Seems like that one is not set up to be embedded. Hopefully this helps save a few headaches.