Build Native Mobile App - Unable to install <App> (on iOS)

Hello,   Problem: I have completed the learning path, Build a Native Mobile Inspection App  and currently testing to distribute the app through the Build Native App feature in Mendix Studio Pro 9.18.0. I am trying to see if the app can be run on my android and iOS device independent from the Mendix testing app, Make It Native 9, not trying to distribute to either Play Store or Apps Store. I ran into an error, “Unable To Install <App>” on my iOS device, and the app distributed to my android device would just stuck at the splash screen.    Things I’ve tried: I’ve looked into the error message I got from my iOS device from the official apple developer forum and stackoverflow, but I found this to be the most helpful here. I’m using a free apple developer account and created a development provisioning profile manually from XCode. I think the app identifier on both my provisioning file and the Mendix app matches, assuming I received to error message while configuring in the Build Native App feature. I have also made sure that my iOS device’s UDID is included in the provisioned devices in my profile. But the app still wouldn't install on my device. I have also tried deleting the app from the AppCenter and rebuilding it from Mendix again, and distribute the download through email. Recreating provisioning profile and signing certificate from XCode, and rebuild.   Here’s the link to the GitHub repository,   The following information are my configurations for Build app for distribution. Build app for distribution Runtime URL: Build Type: Approach for building app’s source code: Default Configure cloud services Github and App Center API tokens are provided iOS app-id: com-eis-inspectionapp-ios (auto-generated) Android app-id: com-eis-inspectionapp-android (auto-generated) App details: App name: InspectionApp App identifier: com.eis.inspectionapp Bundle name: InspectionApp Orientation selection: Portrait & Landscape Device targets selection: Phones App capabilities: Only Maps is used. API key provided, and Apple Maps for iOS is checked iOS certificates: Provisioning file and certificate set uploaded (no error messages shown)   The following screenshots are for reference: Build app for distribution:    Build type:   App details     App permissions   iOS certificates   I feel like the issue could be more on how I signed the app but I’m not sure. Any thoughts?  
0 answers