Error: Make it Native 9 Connection - Connection Error: Cannot connect with Mendix Studio Pro.

I am working with Mendix 9.24.11, and I created a small Mendix Native App. It is running successfully, but I cannot run it on my Android Smartphone (Samsung Galaxy S20+).   I am trying to start it with the Make it Native 9 App, which I downloaded from Google Play Store.   I am in Home Office. I tried it with the Companies VPN network on, then turned it off, then tried it with my mobile hotspot, and i still get the same following error message:     Any suggestions what I can do to fix it?  Thank you!
3 answers

Hello Shahbaz


This error may occur when you are connected in a network on your server different than your cellphone:


Server: Wifi "NetworkA"

Cellphone: 5G


Try to connect your Cellphone with the same wifi network used by your laptop.

This should solve your problem.


Another alternative is to use an android emulator on your laptop. Is this case, naturally this emulator will be in the same network.


Hi Shahbaz,


I have run into many problems with getting the make it native app to connect with a local running application before.


As Vinicius suggested, first be sure that you are connected to the same network.


No matter how I configure my firewall exceptions, I cannot get my make it native app to connect.  So, if you are on a secure home network, I would suggest disabling your firewall for a short time to test if the make it native app will connect. This will let you know if it is firewall related issue.


I have found that an emulator is the easiest way to accommodate all of my development needs because there are no firewall issues since it is local on your computer.  The downside of emulators is that they require computer resources concurrent with running a local mendix app from studio pro which can slow things down.


Hope this helps!


Hi, It's always better to create a local developer android app and use the same for local android testing. Make it native 9 app published by Mendix is too slow in loading and most of the times it throws this error even if we are on the same network. Thanks!