The data from a List view on a Home_Native page does not appear on the smartphone.

Hello,   I am currently following the Learning Path Build a Native Mobile Inspection App. I am using Mendix Version 9.24.3. I am on Mac M1, with Windows 11 on Parallels Desktop. On my smartphone, I have also installed the Make It Native 9 application. I have made the necessary configurations to access my Mendix application from my smartphone.   I am stuck on chapter 4.2.1. I need to add a List view widget to the Home_Native page. I want to point out that I have previously inserted data into my model via the Responsive Web view and I can see them well.   When I access my application on my smartphone, I do not see the data in the List view of my Home_Native page. Yet I can add normal text and it displays fine. I have tried with Mendix V10.7 and the mobile application Make It Native 10, but I get the same result. I also tried with the final sources (file .mpk) provided with the Learning Path but I got the same result.   Is there a configuration I missed or something I did wrong?   Thank you in advance for your responses,     Have a great day,
2 answers

- Make sure you added data by going to Console -> Advanced -> Start build-in database viewer.

- Check the configuration synchronization in the navigation for the native mobile (tablet & phone) profile.

- Try it on another device.

- Download BlueStacks 5 to test it as android device.


* If all these not working in the proper way, Start a new one with blank template and add native mobile profile manually in the Navigation and download "Native Mobile Resources" from marketplace within studio pro, after that you can go ahead again and implement all learning path step by step


* You can reach out to me if you still get in stuck.


** Kindly  accept my answer if it assist you to solve your problem.


Hello Ahmad,


Thank you for your response.

I have tested your recommendations.


Firstly, my project's database does contain data :

Capture d’écran 2024-02-15 à 23.53.31.png


Secondly, the synchronization configuration of my native mobile navigation is correct :

Capture d’écran 2024-02-15 à 23.56.46.png


I also tried using 3 different Android emulators on my Windows VM (including BlueStacks 5 and Android Studio). Unfortunately, none of them worked. The virtualization of my Windows 11 does not seem to be enabled, but Parallels Desktop does not provide me with an option to enable it.


I also tried starting from a blank app and manually adding components for native mobile. Unfortunately, I encountered the same result.


I still need to try with another phone and investigate how I can enable virtualization on my Parallels Windows VM.


For now, I'm still stuck.