Cannot run npm install in new Phonegap folder

I am following this documentation on creating a Phonegap package. I have downloaded a Phonegap zip, unzipped it locally and tried to run 'npm install' in the root folder. Unfortunately this returns an error: Apart from this log file I also see some errors in Powershell about being unable to resolve 'mustache-loader'.  Removing the node_modules folder and rerunning 'npm install' didn't help either.    Anyone have any idea on how to solve this?
4 answers

Did some troubleshooting with Willem, ended up being a problem with the Node.js version (Need at least version 6). PR added to the repository.


Hi Willem, 

I just tried it on mac and it worked. It might be that you need to run the powershell or cmd as an administrator as it required me to run the install with sudo. 




Fixed by updating nodeJS to the most recent version, removing the node_modules folder and then rerunning 'npm install'.


Original post: 

Because I can't edit my question for some reason. Hereby the error again:


50 error Windows_NT 10.0.15063
51 error argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install"
52 error node v4.4.7
53 error npm  v2.15.8
54 error code ELIFECYCLE
55 error mendix-hybrid-app-template@1.0.3 install: `node init && webpack`
55 error Exit status 2
56 error Failed at the mendix-hybrid-app-template@1.0.3 install script 'node init && webpack'.
56 error This is most likely a problem with the mendix-hybrid-app-template package,
56 error not with npm itself.
56 error Tell the author that this fails on your system:
56 error     node init && webpack
56 error You can get information on how to open an issue for this project with:
56 error     npm bugs mendix-hybrid-app-template
56 error Or if that isn't available, you can get their info via:
56 error
56 error     npm owner ls mendix-hybrid-app-template
56 error There is likely additional logging output above.
57 verbose exit [ 1, true ]



The node.js on Mac or Linux is easily installed.

I do not try to use PowerShell.

Here is for Windows 10:

.NET Framework 4.5.1  only for Windows 7
npm config set python python2.7
npm config set msys_version 2015


Bash on Ubuntu on Windows