Working with the new hybrid app template

Hi guys 'n gals, I was trying to get my app built with phonegap, using the new hybrid app template:\ However, I've been running into some issues, and I was wondering in what way my setup differs from people who DID manage to get it to work. As far as I know the steps should be: Download Zip package from Cloud portal Install NodeJS Unzip  Browse to directory with Powershell / CMD use npm install to download all dependencies use npm run package to create a new zip file with your custom changes   Some information regarding my setup: node -v   npm -v   npm install   As you can see, currently, I can't even seem to get past the npm install part. For some reason this worked yesterday, and my original problem was that the command npm run package -- didn't actually build a package to target my test endpoint, but always gave me a deployment package: the argument wasn't passed on to webpack. As you can tell, I don't even get that far now... I tried clean nodeJS installs, on different PCs, all with the same result.. Am I missing something obvious here? See GitHub for more info:   Any help is greatly appreciated
2 answers


The newer NPM version (5.5.x) doesn't work with the hybrid app template yet, it fails on first run, since there is no build/ directory yet. Current workaround would be to manually create this. Kevin Vlaanderen (creator of the app-template) is pushing a fix somewhere next week. He also said that downgrading to npm 3.10.10 is not recommended.


Currently, my build process works, so i'll close this issue. Just thought i'd supply this 'answer' for future reference.

For more info, check out the GitHub repo @


Hi Paul, I have a working setup with the following versions of npm and node. I did install the 32bit version of nodejs though.