Google maps controls are not shown - iOS devices

Hello guys,  I have noticed that Google maps controls are not shown anymore in my application (Streetview, Zoom Control). If I run the application via browser, then everything works properly, but the problem occurs when I use the tablet or phone device  (Hybrid application and only iOS, with Android devices the widget works properly).  The map works, but I don't see the map controls which are important for our clients. I can confirm that settings are correct within Google Map widget (enabled). The current version of Google Map the widget we use is 5.5. I have tried with the latest version of widget (6.1.1) but no results.  This is strange since the widget worked properly.  Thank you in advance.  Kind regards, David
4 answers

Hello David,


There is an issue with the Maps widget, and I've created a custom patch to it. I would strongly advise contacting the folks behind the original widget and inform them of the breaking behavior.

Bottom line, the problem is in the Google JavaScript API for maps. Once reverting back to the 3.31 (latest is 3.32), all works well.

For now, you can download "fixed" and working widget here:



Hello Petar, 

Thanks :D 


Hello guys, 

The problem with Google controls and Street view has been solved with the latest Hybrid release (4.0.0/4.0.0) since there is change within the following code: 

<allow-navigation href="about:*" />

In the previous package was: 

<allow-navigation href="about:blank" />

This solved the issue with Google maps and I’ve noticed that now is possible to use Waze navigation as external navigation from the application (there was issue also,  on iOS devices) 


I tried every possible fix out there untill i fixed it by turning on the location services.