Q: Locally building offline Mendix application with Phonegap and package issue (Android)

Hey Guys,  About 6 months ago I did not have a problem with building mobile applications locally. Now after downloading the package from Sprintr I get the following error (see img) when trying to use commands: npm run prepare:all / npm run platform:android. I've tried installing the package using npm myself (npm install mendix-hybrid-app-tempalte@2.0.1) which did not solve the problem.  The logs didn't make me any wiser, and since I did not have an issue with this about 6 months ago I'm hoping someone on the forum has encountered this and has a quick fix for this issue.  Sometimes a node version or npm switch helps, additional details below.   Additional, i'm using:  NPM @ 6.1.0 and Node @ 8.2.1 Debug Log additional: mendix-hybrid-app-template@2.0.1~prepare:all: Returned: code: 1  signal: null mendix-hybrid-app-template@2.0.1~prepare:all: Failed to exec prepare:all script Error: mendix-hybrid-app-template@2.0.1 prepare:all: `cd build && phonegap prepare` Exit status 1 at EventEmitter.<anonymous> (C:\Users\username\AppData\Roaming\npm\node_modules\npm\node_modules\npm-lifecycle\index.js:304:16) at emitTwo (events.js:125:13) at EventEmitter.emit (events.js:213:7) at ChildProcess.<anonymous> (C:\Users\username\AppData\Roaming\npm\node_modules\npm\node_modules\npm-lifecycle\lib\spawn.js:55:14) at emitTwo (events.js:125:13) at ChildProcess.emit (events.js:213:7) at maybeClose (internal/child_process.js:921:16) at Process.ChildProcess._handle.onexit (internal/child_process.js:211:5) This log is just to make this question complete, I do not intend to debug library files.  Regards, Jermaine
1 answers

I ran into similar issues this week: After I uninstalled git and reinstalled it my issues went away.