React-native module doesnt seem to work

Hi guys, I’ve implemented a react-native module ( in a simple react-native project and it works great! So I tried adding it to my Mendix project and I followed the steps described in the docs (, and it seems it has been added correctly to my project. But whenever I try to use it it just doesn’t work (even with a simple require) and it just uses the last “working” version of the app. I’m pretty sure something went wrong when adding it to the project but I’m not sure what happened.  If anyone would like to check it out: If someone has any advice or has worked with react-native modules in Mendix, please contact me or answer on this post. Thank you!
2 answers

Hi Guys,

I spent days trying to troubleshoot this issue and the solution is actually quite simple. Once you have created your local native app and added your packages to it;  the next step is to navigate (using command prompt) to your project > javascriptsource> {mendix module}> actions and run “npm install xyz” – whereby “xyz” is the package you are trying to install.

I hope this will help with your future projects.




any luck with that issue?

I have the same issue and I am stuck.