How to create local users and set password

Hello, I have created an app with userroles ‘Beheer’ and ‘Gebruiker’. The userrole ‘Beheerder’ has Administrator privileges. I have created a user called ‘beheerder’ with userrole ‘Beheer’ as Administrator and set a password. When I start the application I get a loginform and I can login with user ‘beheerder’ with the proper login and password, so that's what I expected. I would like  to create a new user (let’s call this user ‘voorbeeldgebruiker’) with userrole ‘Gebruiker’ and set the password. I'm sure it's explained somewhere in the documentation and I have searched, but I just haven't found how to do this; how do I create local users and set their passwords? Thank you in advance for helping me out.
3 answers


As tim suggested you need an ui to do that. So Create a menu item in the navigation which opens the Account_Overview page. This page allows you to create, edit or delete user accounts  and able to set passwords too.

This page is present in Administration Module. 

Use Ctrl+G shortcut and type Account_Overview. You can see the page and connect this page in menu item

Then login as a Admin and then click the menu 

Start creating users.

I hope this helps you


You need a ui that allows you to manage useraccounts. Best thing to do is add the Appstore module Systemmanagement and add the snippet ‘Snip_SystemManagement_Administrator’ to your application, for administrators only.


Thank you both Tim and Stella.

I have created a menu-item in the navigation which opens the Account_Overview page, and I have created a local administrator named ‘lokalebeheerder’ and a local user named ‘lokalegebruiker’.

I can login just fine with both accounts on the localhosted site whcih is cerated when select ‘Run locally’ in Mendix Studio Pro, but I can't login with these accounts if I run my (free) app in the Mendix Cloud; how can I make accounts (both administrator and user) that can also login fine in my app when I run my (free) app in the  Mendix Cloud?



I think I have solved the problem (disabled security, created administrator user, then enabled security).

Both Tim and Stella solutions probably would have worked fine, but since I followed Stella's approach I will mark her answer.