Cant read System.User/Name despite I opted to manage users with that role

Hi. I thought I knew what “User roles → User management” was for, but now I’m unsure. I expected that allowing role A manage members of role B would allow it to retrieve all users with that role and read the Name attribute declared in System.User. Additionally, mapping role A to the module role Administration/User would allow it to retrieve all Administration.Account objects and read the declared attributes of Administration.Account. This worked fine in Mendix 8, but after migrating to Mendix 9 the Reference Selector widget behaves differently. Previously it was retrieving all Administration.Account objects and was displaying Administration.Account/Name = “null” for the accounts we were not allowed to manage. Now a page containing such Reference Selector fails to load and in the console I see: "Read access denied for member 'Name' of object 'Administration.Account" I tried to constrain the selectable objects with the members of role B, but the page was still failing to load. However, allowing role A manage users with “no user roles” magically makes the error go away. And what is even stranger, after removing the selectable objects constraint the dropdown can display the Name of the Administrators role members. P.S. the data grid widget still behaves as expected: for the users I’m not allowed to manage it displays empty strings in the Name column.
1 answers

sounds like a bug – you should file a ticket at