Add button doesnt work

Hi,   I have a button to add an object but if I click on this button I need to log in (screenshot down below) and when I log in it doesn't work either. I tried the visibility with different roles but it didn't work. Also I got other pages to add an object and the add button works on this page. I tried to copy this page and changed the entities but also didn't work.   Anyone who knows how to fix this?  
1 answers

So you want to add/create an account I assume? The object, when not logged in (so as an anonymous user/session) should be able to be created by an anonymous user. If the object you want to create cannot be created by either anonymous users or users without the proper access rules then it wont work. 

If it's an account: make a non persistent entity in a different module (name it AccountCreation or whatveer you want) and let that be created by anonymous users. You can then either use a deeplink to finish it or if you wanna start simple let microflows handle the creation of the account object.  It's just a suggestion but I at least believe your current issue lies in my first paragraph.