Sign In Dialog missing?

I have been developing my App with Project Security turned off - all OK. I have set up Module Roles etc and set Project Security to Prototype/Demo. When I deploy to the Sandbox the App does not show a Sign in dailog and just operates as it did with Project Security tuned off. Any suggestions as to why I'm not being presented with the Sign in dialog? Probably just a red herring but I upgraded the Modeller (6.5.0 to 6.9.1) just before changing the Project Security. When I Run Local the Sign in dialog works fine (there are no entries in the App Cloud Users page). When I Run in the Sandbox (there is a single entry in the App Cloud Users page which shows my credentials) the Sign in does not appear. Update - For some unknown reason the Sign in dialog is now appearing in the Sandbox version so problem has gone away! Thanks.
1 answers

I think this has to do with your Mendix ID. You were probably logged in in your Mendix ID in the browser in which you opened your Sandbox app. I believe Mendix performs a Single Sign On with your Mendix ID. This explains why you didn't see your login screen. Be sure to place a sign out button somewhere in your app to be able to sign out and sign in as a different user. You can also try to go to your applicationURL/login.html, this should always bring up the login page.