Enabling Production security level setting is showing wrong home page

Enabling Production security level setting is showing wrong home page. If I turn if off then it is showing correct home page that I configured. I have provided the access to all pages, microflows and entities in the Module security   Below home page is shown. Not sure from where it is picking
2 answers

This is standard behavior. 

Because you set security a user will need to log in before making use of the application. This is the default Mendix login screen used for that.

If you want to enable production level security but do not want users to require to log in for (certain) page you will need to give security access to the role: Anonymous. And set a specific homepage for Anonymous users as well.

The only other issue could be that your homepages or permissions for pages aren't set correctly, but that's AFTER logging in.

More information here: https://docs.mendix.com/refguide/project-security

and the learning here: https://gettingstarted.mendixcloud.com/link/module/9/lecture/118


The only reason for the system for not showing the page you expected is security. So double check that the user is entitled to read all the objects in your home screen.