Blank page after logging in via XSUAA

Hi again to all of you! I've got the following problem:  I've deployed my app without any security turned on to the cloud which was no problem. After turning on security and adding the Odata connector and the XSUAA Module to my app, I get redirected to a blank page by logging in with my SAP credentials. I simply click on "Login via XSUAA", insert my credentials and get redirected to a blank page! Locally, it goes well. As well, when e.g. I insert the wrong password, it is recognized and it won't direct me anywhere (so the synchronisation with SAP obviously is fine). I already did the mapping of the roles within my Sap cloud account, but I've also tried it without changing anything in my cloud account. The problem is, a colleague of mine can accomplish the login via XSUAA module without any mapping, so this doesn't seem to be the problem (as far as I see). The log data to the app is the following: I guess the yellow lines are problematic here, but I am not sure how to solve it - did anyone of you already had this and knows how to solve it?   I am grateful for any tips! Thanks in advance, Laura   Edit: This is the list of all objects in my userlib folder:   Edit 2 SOLUTION: I took the userlib content of another app and just copied it into the folder of my inital app (of course, before that, I deleted the content of it). After that, the error doesn't occur anymore! Mendix runtime starts succesfully! The question now is:  Why did the content of the original userlib folder produce such an error (respectively, why did it grow so big?) The content of the userlib folder with which the error didn't occur anymore was the following: Edit 3 : When importing the Mx reflection / excel importer / exporter module, the userlib changes so that no XSUAA is possible anymore...
3 answers

Check your userlib folder,

probably you have multiple commons.codec versions in there. You should only keep the latest one.

regards, Fabian



which versions of org.apache.servicemix.bundles.commons-codec are you using?



I have the same exception and as per the suggestion I have removed the old jars (e.g. commons-codec-**.jar). After redeploying into SAP cloud and restarting the same error still occurs i.e. blank after login. I assume that deployment directory is not getting cleaned? How to fix this ? I also experimented by switching the DEVELOPMENT_MODE to false hoping it would clean deployment directory. That too didnt help.
So i am still stuck with this below exception:
CRITICAL - M2EE: java.lang.NoSuchMethodError: org.apache.commons.codec.binary.Base64.decodeBase64(Ljava/lang/String;)[B
at com.auth0.jwt.JWTDecoder.<init>(
at sapauthentication.actions.StartXsuaaIntegration.retrieveClaimsFromAuthorityAccessToken(