Cant sign in when I run locally my app

Greetings, I’ve just started exploring Mendix today and now I’m following the Become a Rapid Developer learning path.   When I try to run locally my tutorial app, I just can’t pass the sign in screen in the viewer. I tried the MxAdmin and 1 combination. I tried to set the security off. But still couldn’t get pass the sign in page to test my app.   Even the downloadable completed project file has the same problem.   What am I missing ? Thanks.   Tolga
2 answers

Hi Tolga,

The MxAdmin password can be set in the security settings in the project module. When you open up the settings there will be a tab called “administrator” where you can set the mxadmin password.


If you are running in the cloud then you can use the community commons microflow called “CreateUserIfNotExists” in your after start up microflow.

Download the community commons module from the app store, by clicking the shopping cart at the top right corner of the module. Once thats downloaded go to the project settings and create a microflow to run after start up. In that microflow call the “CreateUserIfNotExist” microflow and configure the parameters to set the username and password. 


Here is an example of an after start up microflow.


If you want to download the microflow you can copy the link below and import it into your project.

Hope this helps!


Still, I can’t login my sample app. This is the project I downloaded from the learning path and haven’t modified it.

I’ve turned off the security as shown here :

I run it locally and it gives me the login screen anyhow.

I type in the administrator information. It doesn’t give an error but cycles through the same login screen endlessly.

What’s going wrong, what am I missing here, I’m really curious.

Thanks for any kind of help !