Issue with attribute read only when trying to connect multiple tables.

Hello!   right now I'm working on a small project where I need to make sure that a purchase-order gets the right products attached to it. I tried to do this by using the following domain model: After this i tried to make it so that when you make a "VerkooporderRegel” it should give a drop down menu of the already exsisting: “Verkooporders” and “Artikelen”: But because both of those are autonumbers i get the following error:  widget must be read only. It is connected to attribute "MyFirstModule.Artikel.ArtikelID”, which is a read-only, because it is an auto-generated number. I've now been stuck on this for multiple hours. The reason why I'm doing it this way is because I have done it like this before in version 7.23.3 and back then it worked. Does anyone have any idea what I'm doing wrong?   Thanks for taking the time to read this!   With kind regards,   Max
2 answers

Hi Max,

You are using a Text Box Input widget which is designed to allow a user to modify that attributes value. Since that attribute is an Auto-Number, which is automatically generated by the platform, you get an error.

It sounds like what you actually want to do is set the association to an existing VerkoopOrder / Artikel. This can be done via the ‘Reference Selector’ input widget. This will give you your drop down.


That worked perfectly!