Merge problems while migrating from 7 to 8

I am migrating an application from mendix 7.23.8 to mendix 8.6.2. I created a branch from main, upgraded the branch and executed regression tests. Everything works fine, but merge to main does not seem possible. I opened mainline using Mendix 8.6.2. No commits were done in the main line, so main was still in mendix 7.23.8. Opening main in Mendix 8.6.2 forces mainline to convert to 8.6.2 and svn to upgrade. This finished normally. Then i tried to merge all changes from the mendix 8 conversion branch to main, but now i am faced with over 1000 errors, a lot of merge conflicts and duplicate appstore modules. I tried many solutions, like a partial merge and manual solution of conflicts. None got anywhere near reliable results. The only scenario that worked for me: - open mainline in Mendix 7.23.8. In place conversion takes place and svn gets upgraded. - commit nothing, close mendix studio. - open SmartSVN and revert all changes. - merge the mendix 8 branch to main using SmartSVN. Result: no conflicts and a seamless merge. Is this normal? I do not think this is how it is supposed to work, is it? Am i doing something wrong?
1 answers

I can't comment on the is this normal part, but I have seen this in many occasions where the branch was upgraded before the mainline. Because of these issues the best practise I follow is to always upgrade the mainline first, do a test in a branchline created from the main first of course (and after succes throw this new branchline in the trash)