HTTP Error 500 when running Mendix App locally

Hello, In our project we currently have the problem, that some developers run into a HTTP ERROR 500 when running the app locally and viewing it in the browser. In our project we are currently working with Mendix 8.8.1. We tried to compare the following between my machine where it works and the machines where it doesn't. None of it helped. Comparing the Errors in the Mendix Console when running locally. Yes there is an error, but also on my machine, where it works perfectly (see screenshot attached) Comparing the complete project settings (esp. Runtime, Anonymous users and security. They are all the same. Trying with different branches and rolling back to older versions Setting breakpoints in the microflows which are used after startup (Esp. in SiemensEntitlementSSOIntegration.ASU_OpenIDConnect_Start since we use the Siemens Entitlement Module. We assumed the problem could come from this module, but we could not link the Error 500 to any called microflows.) Comparing Firewall settings   Since we couldn't figure out what exactly causes the Error 500 - Is it possible to access logs of the local server which could contain further information? What could be another approach to find the cause for this error?   Thank you for any hints!  
3 answers

Could the error in your startup cause the problem? The one with OpenIDConnect? Do you use it for logging in? Do you see it on your local?


Hi Martin,


Thanks for your reply. Yes we use OpenIDConnect, which does not work locally. However the fallback should be the standard Mendix Login page. Here the screenshot from my machine:

To create that screenshot I used a branch which a colleague created and he ends up with the HTTP 500. I did not change any settings. The console looks the same on my machine.

From my understanding the OpenIDConnect Error appears in startup, however, the HTTP500 appears later, as soon as somebody accesses the page. Except in the Browser I don’t see any further information what casues that error.

Are there access logs written anywhere else?



We found a workaround which solves the problem temporarily.

It seems like, that Mendix does not always recompile when starting the project locally.

We have set the “Allow anonymous users” for running locally to “Yes”, which did not solve the problem.

However changing it to “No”, Saving and starting, again ending up with the error and then changing it back to “Yes” and starting again solved it.


This workaround solved the problem on three different machines.

In short:

Initial setting to “Yes” → Error, Change to “No” → Error, change back to “Yes” → works.


We will use this workaround now whenever we run into that problem again.

If anyone knows this kind of behaviour and has a better solution, please let us know. Thank you.