Unable to Run Locally Native App Project

I have a native app project which was working fine in Mendix 8.9.0. I opened it with Mendix 8.11.0 and upgraded the project. When I run locally the web part of app starts and I can view web application but native app does not start and and error message is displayed which is mentioned at end. In view mendix app it says “application must be running before connection specific info can be displayed” Native packager failed to start. Native packager logs: C:\Program Files\Mendix\\modeler\tools\node\node.exe "C:\Program Files\Mendix\\modeler\tools\node\node_modules\react-native\local-cli\cli.js" start --port "8083" --config "C:\Users\ushabbir\Documents\Mendix\App-main\deployment\native\metro.config.json" warn Failed to chmod xsel: EPERM: operation not permitted, chmod 'C:\Program Files\Mendix\\modeler\tools\node\node_modules\react-native\node_modules\@react-native-community\cli\build\commands\server\external\xsel' ┌──────────────────────────────────────────────────────────────────────────────┐ │ │ │ Running Metro Bundler on port 8083. │ │ │ │ Keep Metro running while developing on any JS projects. Feel free to │ │ close this tab and run your own Metro instance if you prefer. │ │ │ │ https://github.com/facebook/react-native │ │ │ └──────────────────────────────────────────────────────────────────────────────┘ Looking for JS files in C:\Users\ushabbir\Documents\Mendix\App-main\deployment\native C:/Users/ushabbir/Documents/Mendix/App-main/theme C:/Users/ushabbir/Documents/Mendix/App-main/javascriptsource C:/Program Files/Mendix/ 2020-07-21T12:52:25,221: [cli] unable to talk to your watchman on \\.\pipe\watchman-ushabbir! (No such file or directory) Watchman: watchman --no-pretty get-sockname returned with exit code=1, signal=null, stderr= 2020-07-21T12:52:25,221: [cli] unable to talk to your watchman on \\.\pipe\watchman-ushabbir! (No such file or directory) tc tc  
2 answers

Good Day,

I did not currently didn’t have any windows updates that are required.

I restarted my windows 10 device, reinstalled Mendix 8.18.5, but the issue persisted when I tried to re-run the native project.

I created another branch (this time ensuring that there were no special characters in my branch name – ‘&’) and the native project launched just fine…. The smallest things...


Windows Update solved the issue. 
- Check for updates manually

- Download and Install all available updates. Restart when required.
- After restart check for updates again to make sure all updates have been installed
- Reinstall Mendix Studio Pro