sftp module error - on Mendix 8.10

Hi, I managed to get the sftp connector working installed and running. Tried to add sftp configuration of localhost – which worked perfectly fine. However trying to add a subsequent one or to edit the name of the existing one throws the following errors : Error while encrypting string: Key should not be empty Uploading file failed: Failed to commit [User 'demo_administrator' with session id '2ddd1b90-XXXX-XXXX-XXXX-XXXXXXXX8c4c' and roles 'Administrator'] Uploading file failed: Failed to commit Error: Uploading file failed: Failed to commit LOG TRACE     com.mendix.core.CoreRuntimeException: Failed to commit     at com.mendix.basis.component.CommitHandler.commit(CommitHandler.scala:151) Caused by: com.mendix.core.CoreRuntimeException: com.mendix.modules.microflowengine.MicroflowException: com.mendix.systemwideinterfaces.MendixRuntimeException: com.mendix.systemwideinterfaces.MendixRuntimeException: Key should not be empty     at Encryption.Encrypt (Error : '')     at SFTP.BCo_Key (SubMicroflow : 'Encrypt')     at {"before":[{},{}],"action":{"type":"CommitAction"},"after":[],"type":"EventExtendedAction"} Advanced stacktrace: Screen Below – shows one sftp config added and works fine   However, adding subsequent ones, show errors like below – error log outputs as given above   Encryption Set as Given Below: Any help will be appreciated here.
1 answers

Have you set the encryption key constant in the Encryption module?