Seeing Error on running a particular microflow during commit

This particular microflow was working fine, but out of nowhere it stopped working correctly with below screenshot. ( other microflow are running fine ) the microflow is able to perform the required tasks and in the end it is supposed to create a database record by commit object. it is showing below error. although all tasks are done, record is not created to see on the page. there is no information on this error. i tried using debug but nothing in the logs either.. anyone seen this before..
2 answers

Have you tried putting a breakpoint on the first action in the  microflow and single stepping through it to see if it runs, and if it does, where it breaks?

If it’s the commit action that you think is failing, it could be a permissions problem.


Few thoughts form my side

  1. When deploying locally, making changes to pages and/or microflows results in a quick reloads on a re-run.
    Sometimes the fast reload causes that the DB connection is broken. hard stop, restart solves this
  2. In relation to previous; having multiple tabs open of the same app running locally and rerunning it; Can cause that opened pages with data in different tabs might give errors.
  3. What is the language of the app? since the popup is empty, my gut feeling tells me that you aren’t using the EN_US language as default and uses a different language w/o translation of the system texts. If I’m correct; translate them first, so that you at least know the message
  4. Do you run the microflow with or without security applied? Because when applied and user doesn’t have the right access rights, this will cause an error
  5. Responsecode 551 doesn’t rings a bell with me