Cant find public key in the key ring while encrypting a file.

Hi all, We are trying to make a integration with a SFTP server in which we can upload and download certain files via our app.  I downloaded the SFTP module from Mendix and configured it. I created a key pair and gave the public key to the partner we want to connect with. After the partner installed the key we tried to connect with the SFTP server, and it was a success. We could see and navigate through folders on the server. When we tried to upload a document to the server, the module said it was a success. But we couldn’t see the document on the server. Our partner told us that document was received but was automatically rejected because it wasn’t encrypted the right way. He told us the document should be signed with our private key and encrypted with their public key and then uploaded to the server. I downloaded the latest version of the encryption module and configured it with our private key and their public key, but when I try to encrypt de document I get the following error:  Can't find public key in the key ring. Does someone know how to resolve this error? And is using the encryption module the right way? Or should the SFTP module handle the encryption of the files automatically? Thank in advance for your response.       A few things I already tried: I tried to change the format of the public key. I tried to add the certificate tree which is a .P7B file to my Mendix studio pro. But that is not possible, so I download the certifcates in the chain separately and added them to my Mendix studio pro.    
0 answers