oData issue

Hi, I have successfully fixed the issue. I need to add anonymous roles for every entity. Before this, I did not add the anonymous role because the form is not used by the anonymous. Thanks for your suggestion. Does anyone know how to fix this issue? I have exposed an entity as an oData resource that can be used in Excel in feature. but when put the link into Excel to get data, the table/attribute from Mendix did not appear on the Navigator page, the page that we will Load/Transform Data. I have to try at the test server, it still did not appear any tables.    oData configuration:   Get Data configuration:   From lin localhost:8080/odata/QMS_iMODA/v1/$metadata   Thanks for you help.  
2 answers

Do note that OData respects all the security rights. So has the user account that retrieves the data all the rights to read that data? So double check your security.





I tried the ODATA exposure in one of my local without authentication and it worked.

As Ronald suggested, it might have to do with your security. May be try disabling the authentication and check once again.

If it works, then you must look in to your security. You can also try accessing this URL from browser to see if atleast the metadata information is loaded.

Another reason, if there are lot of data, when you are trying to load in Excel, it takes sometime. So, IMHO the loading time depends on the amount of data also.

When you are deploying this in your Mendix cloud, please ensure if you are enabling this link. Read https://docs.mendix.com/developerportal/deploy/access-restrictions