from Atlas UI 2 to Atlas UI 3

I have converted an app from version 8.18 to version 9.6 And after that migrated from Atlas UI 2 to Atlas UI 3, I am also using custom branding and followed the​​​​​​​ guide. I am still getting this error and do not know how fix it. Theme settings could not be read successfully: - Error converting value “WebModeler” to type ‘Mendix.Modeler.WebUI.Atlas.DesignProperties.DesignPropertyJson[]’.Path ‘pageTemplates’, line 2, position 37, (in themesource\somemodule\web\design-properties.json)
2 answers

I ran into the same issue, it was caused by some attributes in the .json which are no longer needed in Atlas 3.

I solved it by removing the "pageTemplates", "cssFiles" and "designProperties" attributes.

So starting your .json at Widget level.


Hi Tedros,

If I understand you updated everything in Studio Pro. Have you also tried opening the app in the online Studio? Some things like Branding are easier to update/fix there. Maybe opening the app in Studio will fix it? Hope this helps!