App cant start

The application shows error “Something went wrong” and couldn’t start, the console shows the below error   java.util.NoSuchElementException: None.get     at scala.None$.get(Option.scala:627)     at scala.None$.get(Option.scala:626)     at com.mendix.modules.microflowengine.actions.impl.CoreMicroflowActionFactory.createJavaAction(CoreMicroflowActionFactory.scala:97)     at com.mendix.modules.microflowengine.actions.impl.CoreMicroflowActionFactory.createMicroflowAction(CoreMicroflowActionFactory.scala:41)     at com.mendix.modules.microflowengine.actions.impl.CoreMicroflowActionFactory.create(CoreMicroflowActionFactory.scala:37)     at com.mendix.modules.microflowengine.actions.impl.MicroflowActionRegistry.$anonfun$registerMicroflowActionFactory$2(MicroflowActionRegistry.scala:15)     at com.mendix.modules.microflowengine.actions.impl.MicroflowActionRegistry.createMicroflowAction(MicroflowActionRegistry.scala:34)     at com.mendix.modules.microflowengine.actions.impl.MicroflowActionBuilder.createMicroflowAction(MicroflowActionBuilder.scala:24)     at com.mendix.modules.microflowengine.microflowstructure.MicroflowStructureFactory.processActivity(     at com.mendix.modules.microflowengine.microflowstructure.MicroflowStructureFactory.createMicroflowStructure(     at com.mendix.modules.microflowengine.internal.MicroflowEngineModuleImpl.$anonfun$reload$2(MicroflowEngineModuleImpl.scala:34)     at scala.collection.IterableOnceOps.foreach(IterableOnce.scala:563)     at scala.collection.IterableOnceOps.foreach$(IterableOnce.scala:561)     at scala.collection.AbstractIterable.foreach(Iterable.scala:926)     at scala.collection.IterableOps$WithFilter.foreach(Iterable.scala:896)     at com.mendix.modules.microflowengine.internal.MicroflowEngineModuleImpl.reload(MicroflowEngineModuleImpl.scala:33)     at com.mendix.basis.impl.MxRuntimeImplBase.initializeModules(     at com.mendix.basis.impl.MxRuntimeImplBase.doFire(     at com.mendix.basis.impl.MxRuntimeImplBase.fireZeMissiles(     at com.mendix.basis.impl.MxRuntimeImplBase.start(     at com.mendix.m2ee.appcontainer.actions.StartAction.startRuntime(StartAction.scala:30)     at com.mendix.m2ee.appcontainer.actions.StartAction.execute(StartAction.scala:17)     at com.mendix.m2ee.appcontainer.server.handler.HttpAdminHandlerBase.service(     at javax.servlet.http.HttpServlet.service(     at org.eclipse.jetty.servlet.ServletHolder.handle(     at org.eclipse.jetty.servlet.ServletHandler.doHandle(     at org.eclipse.jetty.server.handler.ScopedHandler.nextHandle(     at org.eclipse.jetty.server.handler.ContextHandler.doHandle(     at org.eclipse.jetty.server.handler.ScopedHandler.nextScope(     at org.eclipse.jetty.servlet.ServletHandler.doScope(     at org.eclipse.jetty.server.handler.ScopedHandler.nextScope(     at org.eclipse.jetty.server.handler.ContextHandler.doScope(     at org.eclipse.jetty.server.handler.ScopedHandler.handle(     at org.eclipse.jetty.server.handler.HandlerWrapper.handle(     at org.eclipse.jetty.server.Server.handle(     at org.eclipse.jetty.server.HttpChannel.lambda$handle$1(     at org.eclipse.jetty.server.HttpChannel.dispatch(     at org.eclipse.jetty.server.HttpChannel.handle(     at org.eclipse.jetty.server.HttpConnection.onFillable(     at$ReadCallback.succeeded(     at     at$     at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.runTask(     at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.doProduce(     at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.tryProduce(     at     at org.eclipse.jetty.util.thread.ReservedThreadExecutor$     at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(     at org.eclipse.jetty.util.thread.QueuedThreadPool$     at java.base/  
3 answers

We have seen this error (/this exact stack trace) before. In such cases it was caused by having a microflow with a submicroflow call, where you have selected to run the microflow call in a task queue, but haven't selected what task queue. This results in an incorrect state for the microflow. In 9.14.0, this issue is resolved. 
You could encounter this bug by: 

  • Checking the task-queue execution checkbox and then not selecting a queue and just clicking OK.
    • The checkbox will then be reset, but due to a bug, the queue settings were left in place (without a queue), causing this error. 

To prevent this issue from occurring in the future we suggest the following:

  • If you check the task-queue execution checkbox, please ensure to select a queue.
  • If you happen to check the task-queue execution checkbox, and do not select queue and select OK, then you will need to remember to check and uncheck once again.

So if you recently added/edited a "Call Microflow" action, it could help to check (and save the form) and uncheck the "Execute in the Task Queue" checkbox. Does that ring a bell/does that help? 


I think you are putting a value that is no value into one of your Java actions. Maybe you are not filling in the object correctly or you removed something by accident. Maybe you can look to the specific action and check everything that has something to do with it. Hope you can work it out :)


Hi Mohamed,

Not sure if you have fixed your issue. I have come across the same issue yesterday and I fixed it.

Thank you Melvin and Chris for your tips, my colleague and I have followed the Java action tip and were able to solve our issue.

My scenario is as below:

I have duplicated a microflow with a StartImportByTemplate java action and only changed some activities in the duplicated microflow. That’s when I couldn’t start my project with the very same error message. I could get my project running again after creating a fresh microflow with the same activities I needed in the duplicated microflow. However, my colleague has tried to just delete the Java action and create a new activity and it worked for her but not me.

Not sure what happened with the duplicated microflow there but it’s solved :D

Hope you’ve gotten it worked out.