Data snapshot is conflicted

Hi there, A coworker of mine ran into an issue where they tried to update and were met with an error that “” was conflicted (In Mendix 9.3.0). We tried removing the data-snapshot, the deployment data, Mendix-Cache, creating a new data-snapshot, restarting Mendix, restarting the PC, and etc. Another coworker even committed their data-snapshot, but that didn’t work either. We ended up resolving the issue by having someone make changes and commit as normal (Why the previous data-snapshot commit didn’t resolve the issue, I don’t know). Then, my coworker updated again and it worked, although I believe he said that it showed the error again and then “Update has completed successfully”. I just wanted to put this here since I couldn’t find any forum posts about this issue. Hopefully this helps someone else in the future, and maybe someone can tell us what went wrong? Obviously the data snapshot conflicted, but we don’t quite know why that happened and why it required someone else to commit to resolve.
0 answers